CVE-2026-35391: bulwarkmail webmail · Use of Less Trusted Source
Affects bulwarkmail webmailSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 1.4.11 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.11
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade webmail and bulwarkmail/webmail to 1.4.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| bulwarkmailwebmail | Affected
| Fixed in
|
GitHubbulwarkmail/webmailpkg:github/bulwarkmail/webmailOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Bulwark Webmail to version 1.4.11 or later, where this vulnerability is fixed. Since the vendor advisory confirms the issue is resolved in 1.4.11, applying this official fix is the recommended remediation. No other mitigation steps are indicated.
Description
CVE-2026-35391 is a high-severity vulnerability in Bulwark Webmail versions prior to 1.4.11. The vulnerability arises because the getClientIP() function trusts the first entry of the X-Forwarded-For header, which can be manipulated by an attacker. This allows attackers to forge their source IP address, potentially bypassing IP-based rate limiting and enabling brute-force attacks against the admin login. Additionally, attackers can forge audit log entries to mask malicious activity. The issue is fixed in version 1.4.11.