Skip to main content
VulnerabilityPublished Updated

CVE-2026-35587: nicolargo glances · Server-Side Request Forgery (SSRF)

Affects nicolargo glancesSource CVE Database V5

0
Compare

Public exploit available · CVSS 7.3 High : upgrade to 4.5.4 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade glances and nicolargo/glances to 4.5.4.

Affected software

ProductAffectedFixed in
nicolargoglancesAffected
  • <4.5.4
Fixed in
  • 4.5.4
GitHubnicolargo/glancespkg:github/nicolargo/glancesOther threatsAffected
  • <4.5.4
Fixed in
  • 4.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Glances to version 4.5.4 or later, where this SSRF vulnerability is patched. Until the upgrade, restrict access to the Glances configuration to trusted users only to prevent unauthorized modification of the public_api parameter. No other vendor advisory or patch links are provided, so check the official Glances release notes for confirmation and further guidance.

Description

Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, a Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation of the public_api configuration parameter. The value of public_api is used directly in outbound HTTP requests without any scheme restriction or hostname/IP validation. An attacker who can modify the Glances configuration can force the application to send requests to arbitrary internal or external endpoints. Additionally, when public_username and public_password are set, Glances automatically includes these credentials in the Authorization: Basic header, resulting in credential leakage to attacker-controlled servers. This vulnerability can be exploited to access internal network services, retrieve sensitive data from cloud metadata endpoints, and/or exfiltrate credentials via outbound HTTP requests. The issue arises because public_api is passed directly to the HTTP client (urlopen_auth) without validation, allowing unrestricted outbound connections and unintended disclosure of sensitive information. Version 4.5.4 contains a patch.

References

Community reviews

Loading reviews…