Skip to main content
VulnerabilityPublished

CVE-2026-39333: ChurchCRM CRM · Cross-site Scripting

Affects ChurchCRM CRMSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 7.1.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade CRM and churchcrm/CRM to 7.1.0.

Affected software

ProductAffectedFixed in
ChurchCRMCRMAffected
  • <7.1.0
Fixed in
  • 7.1.0
GitHubchurchcrm/CRMpkg:github/churchcrm/CRMOther threatsAffected
  • <7.1.0
Fixed in
  • 7.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ChurchCRM to version 7.1.0 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Until upgrading, restrict access to authenticated users and avoid clicking untrusted URLs containing the vulnerable parameters.

Description

ChurchCRM is an open-source church management system. Prior to 7.1.0, he FindFundRaiser.php endpoint reflects user-supplied input (DateStart and DateEnd) into HTML input field attributes without proper output encoding for the HTML attribute context. An authenticated attacker can craft a malicious URL that executes arbitrary JavaScript when visited by another authenticated user. This constitutes a reflected XSS vulnerability. This vulnerability is fixed in 7.1.0.

References

Community reviews

Loading reviews…