CVE-2026-40394: Varnish Cache · Always-Incorrect Control Flow Implementation
Affects Varnish CacheSource CVE Database V5
Not known to be exploited · CVSS 4.0 Medium : upgrade to 9.0.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 12 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Varnish Cache to 9.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| varnish-softwareVarnish Cache | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, consider limiting exposure to untrusted HTTP/2 traffic or disabling HTTP/2 support if feasible to reduce risk.
Description
Varnish Cache versions prior to 9.0.1 and Varnish Enterprise before 6.0.16r11 contain a vulnerability that can cause a denial of service via a workspace overflow leading to a daemon panic. This occurs during the HTTP/2 session upgrade process when buffer allocation splits the original workspace, and certain amounts of prefetched data cause pipelining operations to exhaust the workspace. The vulnerability is identified as CWE-670, relating to always-incorrect control flow implementation.