Skip to main content
VulnerabilityPublished

CVE-2026-41129: craftcms cms · Server-Side Request Forgery (SSRF)

Affects craftcms cmsSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.5 Medium : upgrade to 5.9.15 or 4.17.9 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.15, 4.17.9, 5.0.0 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade cms to 5.9.15 or 4.17.9; craftcms/cms to 5.0.0 or 4.17.0.

Affected software

ProductAffectedFixed in
craftcmscmsAffected
  • >=5.0.0-RC1 <5.9.15
Fixed in
  • 5.9.15
craftcmscmsAffected
  • >=4.0.0-RC1 <4.17.9
Fixed in
  • 4.17.9
GitHubcraftcms/cmspkg:github/craftcms/cmsOther threatsAffected
  • <4.17.0
  • <=4.17.8
  • <5.0.0
  • <=5.9.14
Fixed in
  • 4.17.0
  • 5.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Craft CMS to version 4.17.9 or later if using the 4.x branch, or to version 5.9.15 or later if using the 5.x branch. These versions contain patches that fix the SSRF vulnerability. No other mitigation steps are indicated by the vendor advisory.

Description

Craft CMS versions 4.x through 4.17.8 and 5.x through 5.9.14 contain a Server-Side Request Forgery (SSRF) vulnerability. Exploitation requires specific GraphQL schema permissions related to editing and creating assets in a volume. The vulnerability is patched in versions 4.17.

References

Community reviews

Loading reviews…