Skip to main content
VulnerabilityPublished Updated

CVE-2026-4169: Tecnick TCExam · Cross-site Scripting

Affects Tecnick TCExamSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium · fixed in 16.6.1 : update Tecnick TCExam when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.6.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
TecnickTCExamAffected
  • 16.0 – 16.6.0
7 affected builds
Fixed in–
GitHubtecnickcom/tcexampkg:github/tecnickcom/tcexamOther threatsAffected
  • 16.0 – 16.6.0
7 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:tecnick:tcexam:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-4169, organizations should upgrade Tecnick TCExam to version 16.6.1 or later, where the vulnerability is patched. In addition, administrators should enforce strict access controls and limit the number of users with administrative privileges to reduce the risk of insider threats. Implementing Content Security Policy (CSP) headers can help mitigate the impact of XSS by restricting script execution sources. Regularly auditing administrator activities and monitoring for unusual behavior can detect attempts to exploit this vulnerability. Web application firewalls (WAFs) configured to detect and block XSS payloads may provide additional protection. Finally, educating administrators about the risks of executing untrusted content and encouraging safe handling of exported XML data can reduce the likelihood of successful exploitation.

Description

CVE-2026-4169 is a cross-site scripting (XSS) vulnerability found in Tecnick TCExam versions up to 16.6.0, specifically in the XML export functionality for users. The flaw exists in the F_xml_export_users function within admin/code/tce_xml_users.php. Exploitation requires an attacker to have administrator privileges to both create and trigger the exploit, limiting its practical impact. The vulnerability allows injection of malicious scripts that could be executed in the context of an administrator's browser session. The vendor has released version 16.6.1 to address this issue.

References

Community reviews

Loading reviews…