Skip to main content
VulnerabilityPublished Updated

CVE-2026-42352: geopython pygeoapi · Server-Side Request Forgery (SSRF)

Affects geopython pygeoapiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 0.23.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.23.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade geopython pygeoapi to 0.23.3.

Affected software

ProductAffectedFixed in
geopythonpygeoapiAffected
  • >=0.23.0 <0.23.3
Fixed in
  • 0.23.3
PyPIpygeoapipkg:pypi/pygeoapiOther threatsAffected
  • <0.23.3 >=0.23.0
Fixed in
  • 0.23.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pygeoapi to version 0.23.3 or later, where this SSRF vulnerability has been patched. Since the vendor advisory confirms the fix in version 0.23.3, applying this official update is the recommended remediation. No other mitigation steps are indicated by the vendor.

Description

pygeoapi is a Python server implementation of the OGC API suite of standards. From version 0.23.0 to before version 0.23.3, OGC API process execution requests can use the subscriber object to requests to internal HTTP services. This issue has been patched in version 0.23.3.

References

Community reviews

Loading reviews…