CVE-2026-43961: vim · Code Injection
Affects vimSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 9.2.0480 soon.
Data as of 30 Oct 2026, 03:45 UTC
Thin evidence
One scorer or none| CNA (redhat) | CVSS 3.1 | 7.8 |
|---|
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-08-19.
- Patch
- Available – fixed in 9.2.0480
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade vim to 9.2.0480.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vimvim | Affected
| Fixed in
|
GitHubvimpkg:github/vimOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Vim version 9.2.0480 or later where this vulnerability is fixed. Until then, avoid browsing untrusted directories or interacting with files from untrusted sources using Vim's netrw plugin. Exercise caution when opening directories that may contain maliciously crafted filenames to reduce risk.
Description
CVE-2026-43961 is a high-severity vulnerability in Vim's netrw plugin that allows arbitrary code execution via crafted filenames. An attacker can create a filename containing quote characters and expression fragments that break out of quoted contexts during mark/unmark operations, enabling execution of arbitrary Vimscript and shell commands with the user's privileges. Exploitation requires local access to place malicious filenames and user interaction to browse the directory with netrw. The vulnerability affects Vim versions prior to 9.2.0480 and has been fixed in version 9.2.0480.
References
- access.redhat.com/errata/RHSA-2026:57614 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-43961 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2460434 (opens in a new tab)
- github.com/vim/vim/security/advisories/GHSA-66hr-7p6x-x5j3 (opens in a new tab)
- openwall.com/lists/oss-security/2026/05/14/7 (opens in a new tab)