CVE-2026-44204: shelf.nu · Improper Input Validation
Affects shelf.nuSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.20.1 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.20.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade shelf.nu and shelf-nu/shelf.nu to 1.20.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Shelf-nushelf.nu | Affected
| Fixed in
|
GitHubshelf-nu/shelf.nupkg:github/shelf-nu/shelf.nuOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Shelf-nu to version 1.20.1 or later, where this SQL injection vulnerability is fixed. Since the vendor has released a fixed version, applying this official patch is the recommended remediation. Patch status is confirmed by the version information in the advisory.
Description
Shelf is a platform for tracking physical assets. From 1.12 to before 1.20.1, a SQL injection vulnerability in the sortBy query parameter on the /assets route allows any authenticated user (any role) to execute arbitrary SQL and read data from any table in the database, including data belonging to other organizations. This vulnerability is fixed in 1.20.1.