Skip to main content
VulnerabilityPublished

CVE-2026-44461: zed · OS Command Injection

Affects zedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 0.227.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.227.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade zed and zed-industries/zed to 0.227.1.

Affected software

ProductAffectedFixed in
zed-industrieszedAffected
  • <0.227.1
Fixed in
  • 0.227.1
GitHubzed-industries/zedpkg:github/zed-industries/zedOther threatsAffected
  • <0.227.1
Fixed in
  • 0.227.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Zed to version 0.227.1 or later, where this vulnerability is fixed. Until upgrading, avoid using untrusted environment variable keys in remote terminal settings to reduce risk.

Description

Zed code editor versions prior to 0.227.1 contain an OS command injection vulnerability due to improper neutralization of special elements in environment variable keys used in remote SSH/WSL command construction. An attacker able to control environment variable keys can inject shell expansions that execute arbitrary commands on the remote host under the victim user's account. This vulnerability is addressed in version 0.227.1.

References

Community reviews

Loading reviews…