Skip to main content
VulnerabilityPublished

CVE-2026-44465: zed · OS Command Injection

Affects zedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 0.227.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.227.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade zed and zed-industries/zed to 0.227.1.

Affected software

ProductAffectedFixed in
zed-industrieszedAffected
  • <0.227.1
Fixed in
  • 0.227.1
GitHubzed-industries/zedpkg:github/zed-industries/zedOther threatsAffected
  • <0.227.1
Fixed in
  • 0.227.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Zed IDE to version 0.227.1 or later, where this vulnerability is fixed. Since the vendor advisory does not provide additional remediation details, applying this official fix is the recommended action. Patch status is not explicitly confirmed in the advisory, but the description states the issue is fixed in 0.227.1, indicating an official fix is available.

Description

Zed IDE versions prior to 0.227.1 contain a vulnerability where opening a folder with a specially crafted . git/config file can lead to remote code execution. This occurs due to improper neutralization of special elements in OS commands related to the core.fsmonitor Git configuration option. The vulnerability is fixed in version 0.227.1.

References

Community reviews

Loading reviews…