CVE-2026-44717: 611711Dark mcp_calculate_server · Code Injection
Affects 611711Dark mcp_calculate_serverSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.1.1 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp_calculate_server and 611711dark/mcp_calculate_server to 0.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 611711Darkmcp_calculate_server | Affected
| Fixed in
|
GitHub611711dark/mcp_calculate_serverpkg:github/611711dark/mcp_calculate_serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade mcp_calculate_server to version 0.1.1 or later, where the vulnerability is fixed. Since the vendor advisory confirms the fix in 0.1.1, applying this update is the primary and recommended remediation. There is no indication of alternative mitigations or temporary workarounds.
Description
MCP Calculate Server is a mathematical calculation service based on MCP protocol and SymPy library. Prior to 0.1.1, the use of eval() to evaluate mathematical expressions without proper input sanitization leads to remote code execution. This vulnerability is fixed in 0.1.1.