Skip to main content
VulnerabilityPublished

CVE-2026-45037: Eugeny tabby · Incomplete List of Disallowed Inputs

Affects Eugeny tabbySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 1.0.232 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.232
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade tabby and eugeny/tabby to 1.0.232.

Affected software

ProductAffectedFixed in
EugenytabbyAffected
  • <1.0.232
Fixed in
  • 1.0.232
GitHubeugeny/tabbypkg:github/eugeny/tabbyOther threatsAffected
  • <1.0.232
Fixed in
  • 1.0.232

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in Tabby version 1.0.232. Users should upgrade to version 1.0.232 or later to remediate this issue. No other official remediation or temporary fixes are documented. Patch status is not explicitly stated in the vendor advisory, but the description confirms the vulnerability is fixed in 1.0.232.

Description

Tabby (formerly Terminus) is a highly configurable terminal emulator. Prior to 1.0.232, Tabby's terminal linkifier passes any detected URI directly to the operating system's protocol handler without validating the protocol scheme. This allows a malicious SSH or Telnet server to send crafted terminal output containing dangerous protocol URIs which Tabby renders as clickable links, triggering arbitrary OS protocol handlers on the victim's machine. This vulnerability is fixed in 1.0.232.

References

Community reviews

Loading reviews…