CVE-2026-45038: Eugeny tabby · Improper Neutralization of Escape, Meta, or Control Sequences
Affects Eugeny tabbySource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 1.0.233 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.233
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade tabby and eugeny/tabby to 1.0.233.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Eugenytabby | Affected
| Fixed in
|
GitHubeugeny/tabbypkg:github/eugeny/tabbyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Tabby to version 1.0.233 or later, where this vulnerability is fixed. Since the vendor advisory does not provide additional remediation details, applying this official fix is the recommended action. Patch status is confirmed by the version update note in the description.
Description
Tabby (formerly Terminus) is a highly configurable terminal emulator. Prior to 1.0.233, since Tabby does not escape control characters from file paths when dragging and dropping a file into it, code execution can be achieved. This vulnerability is fixed in 1.0.233.