CVE-2026-44775: Kareadita Kavita · Missing Authentication
Affects Kareadita KavitaSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.9.0 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Kavita and kareadita/Kavita to 0.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| KareaditaKavita | Affected
| Fixed in
|
GitHubkareadita/Kavitapkg:github/kareadita/KavitaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Kavita to version 0.9.0 or later, where this vulnerability has been fixed. Since the vendor advisory indicates the issue is resolved in 0.9.0, applying this official fix is the recommended remediation. Patch status is not explicitly stated beyond this fix version, so verify with the vendor for any additional updates.
Description
Kavita versions prior to 0.9.0 have a vulnerability where the ReaderController. GetImage endpoint allows unauthenticated access to page images from any chapter in any library. The endpoint accepts an apiKey parameter but does not validate it, enabling attackers to enumerate all content due to sequential entity IDs. This issue is fixed in version 0.9.0.