Skip to main content
VulnerabilityPublished Updated

CVE-2026-45375: siyuan · Cross-site Scripting

Affects siyuanSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.0 Critical · fixed in 3.7.0 : patch siyuan as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.7.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
siyuan-notesiyuanAffected
  • <=3.6.5
Fixed in–
GitHubsiyuan-note/siyuanpkg:github/siyuan-note/siyuanOther threatsAffected
  • <=3.6.5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SiYuan to version 3.7.0 or later where this vulnerability is fixed. Since the vulnerability is resolved in the official release, no additional mitigation is required beyond applying the update. Patch status is confirmed fixed in version 3.7.0.

Description

SiYuan versions up to 3.6.5 have a critical cross-site scripting (XSS) vulnerability in the Bazaar marketplace UI. The vulnerability arises because the Name and Version fields from plugin-related JSON files are rendered into the UI without proper HTML escaping, allowing malicious HTML to be executed when the marketplace tab is opened. This issue is fixed in version 3.7.0. The vulnerability has a CVSS score of 9.0, indicating critical severity.

References

Community reviews

Loading reviews…