Skip to main content
VulnerabilityPublished Updated

CVE-2026-4600: jsrsasign · Improper Verification of Cryptographic Signature

Affects jsrsasignSource CVE Database V5

0
Compare

Public exploit available · CVSS 9.1 Critical : upgrade to 11.1.1 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.1.1
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade jsrsasign to 11.1.1.

Affected software

ProductAffectedFixed in
jsrsasignAffected
  • <11.1.1
Fixed in
  • 11.1.1
org.webjars.npm:jsrsasignAffected
  • All versions
Fixed in–
npmjsrsasignpkg:npm/jsrsasignOther threatsAffected
  • <11.1.1
Fixed in
  • 11.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

According to the Red Hat advisory, no effective mitigation or patch currently meets their criteria for ease of use, applicability, or stability. Upgrading to jsrsasign version 11.1.1 or later, where this vulnerability is fixed, is recommended when feasible. For affected Red Hat products, consult Red Hat support or your Technical Account Manager for guidance. No temporary workaround is provided.

Description

Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.

References

Community reviews

Loading reviews…