Skip to main content
VulnerabilityPublished

CVE-2026-46496: haxtheweb haxcms-nodejs · Cross-site Scripting

Affects haxtheweb haxcms-nodejsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 26.0.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade haxcms-nodejs and video-player to 26.0.0.

Affected software

ProductAffectedFixed in
haxthewebhaxcms-nodejsAffected
  • <26.0.0
Fixed in
  • 26.0.0
haxthewebvideo-playerAffected
  • <26.0.0
Fixed in
  • 26.0.0
npmhaxcms-nodejspkg:npm/haxcms-nodejsOther threatsAffected
  • <26.0.0
Fixed in
  • 26.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade haxcms-nodejs to version 26.0.0 or later, where the vulnerability has been fixed by properly sanitizing the <video-player> component's source attribute to disallow javascript: URIs. Patch status is confirmed by the vendor's versioning information.

Description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 26.0.0 due to improper sanitization of the `<video-player>` component. The component allows `javascript:` URIs in the `source` attribute, which are executed when the page is viewed. This enables attackers to execute arbitrary JavaScript in the context of the victim’s browser and access sensitive data such as JWT tokens and more. Version 26.0.0 fixes the issue.

References

Community reviews

Loading reviews…