Skip to main content
VulnerabilityPublished

CVE-2026-48527: haxtheweb haxcms-nodejs · Cross-site Scripting

Affects haxtheweb haxcms-nodejsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 26.0.1 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.0.1, 26.0.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade haxcms-nodejs and @haxtheweb/haxcms-nodejs to 26.0.1; haxcms-php to 26.0.2.

Affected software

ProductAffectedFixed in
haxthewebhaxcms-nodejsAffected
  • <26.0.1
Fixed in
  • 26.0.1
haxthewebhaxcms-phpAffected
  • <26.0.2
Fixed in
  • 26.0.2
npm@haxtheweb/haxcms-nodejspkg:npm/@haxtheweb/haxcms-nodejsOther threatsAffected
  • <26.0.1
Fixed in
  • 26.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available: upgrade haxcms-nodejs to version 26.0.1 or later, or haxcms-php to version 26.0.2 or later. Applying these official patches will remediate the vulnerability. No additional vendor advisory was provided; therefore, patch status is based on the version information in the description.

Description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. Versions up to and including 26.0.0 are affected by a stored cross-site scripting (XSS) vulnerability in the `/system/api/saveNode` endpoint. An authenticated user with a permission to edit pages can bypass the HTML sanitizer by injecting an event handler attribute without whitespace before the attribute name. @haxtheweb/haxcms-nodejs 26.0.1 and haxcms-php 26.0.2 patch the issue.

References

Community reviews

Loading reviews…