CVE-2026-46511: haxtheweb haxcms-nodejs · Cross-site Scripting
Affects haxtheweb haxcms-nodejsSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 26.0.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade haxcms-nodejs and haxcms-php and haxtheweb/haxcms-nodejs to 26.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| haxthewebhaxcms-nodejs | Affected
| Fixed in
|
| haxthewebhaxcms-php | Affected
| Fixed in
|
GitHubhaxtheweb/haxcms-nodejspkg:github/haxtheweb/haxcms-nodejsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to haxtheweb haxcms-nodejs version 26.0.0 or later, where this vulnerability is patched. No other official remediation or temporary fixes are indicated. Until upgraded, restrict authenticated user privileges and monitor for suspicious activity related to token exposure.
Description
HAX CMS helps manage microsite universe with PHP or NodeJs backends. Prior to version 26.0.0, an attack chain utilizing Stored XSS alongside dynamic token exposure in the `/system/api/connectionSettings` endpoint allows an authenticated attacker to perform a complete cross-tenant account takeover. The API dynamically leaks the active session's authentication tokens (including the `jwt`, `user_token`, `site_token`, and `appstore_token`) into a global JavaScript variable (`window.appSettings`). An attacker can exploit the XSS vulnerability to force a victim's browser to silently fetch their specific connection settings, extract the tokens, and exfiltrate them to an attacker-controlled webhook. Version 26.0.0 patches the issue.