CVE-2026-46745: Apache Airflow FAB provider · (LDAP Injection)
Affects Apache Airflow FAB providerSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.6.4 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.6.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 25 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow FAB provider and apache-airflow-providers-fab to 3.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow FAB provider | Affected
| Fixed in
|
PyPIapache-airflow-providers-fabpkg:pypi/apache-airflow-providers-fabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade apache-airflow-providers-fab to version 3.6.4 or later, where the vulnerability is fixed. If an immediate upgrade is not feasible, disable LDAP authentication until the provider can be updated to prevent exploitation.
Description
Apache Airflow FAB Auth Manager has an LDAP injection vulnerability (CWE-90) that allows unauthenticated attackers to exfiltrate directory data or bypass authentication. This affects versions prior to 3.6.4 of the apache-airflow-providers-fab package. The vulnerability has a medium severity with a CVSS score of 5.3. Users are advised to upgrade to version 3.6.4 or later. If upgrading immediately is not possible, disabling LDAP authentication is recommended until the provider is updated.