Skip to main content
VulnerabilityPublished

CVE-2026-48721: warpdotdev warp · Incorrect Behavior Order: Validate Before Canonicalize

Affects warpdotdev warpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 0.2026.05.13.09.15.stable_01 soon.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.2026.05.13.09.15.stable_01
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade warpdotdev warp to 0.2026.05.13.09.15.stable_01.

Affected software

ProductAffectedFixed in
warpdotdevwarpAffected
  • >=0.2025.10.08.08.12.stable_00 <0.2026.05.13.09.15.stable_01
Fixed in
  • 0.2026.05.13.09.15.stable_01

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Warp version 0.2026.05.06.15.42.stable_01. Users should upgrade to this version to remediate the vulnerability. Patch status is not explicitly confirmed beyond this version information; therefore, verify with the vendor advisory for the latest remediation guidance.

Description

Warp is an agentic development environment. From 0.2025.10.08.08.12.stable_00 until 0.2026.05.06.15.42.stable_01, Warp contains a command execution permission-check bypass in the default unsandboxed CLI agent profile. The CLI profile is non-interactive and relies on a command denylist as a safety boundary for commands that should require confirmation. Because command strings were checked before canonicalizing leading environment-variable assignments, an attacker who can influence the agent's command output may cause denylisted commands to be treated as non-denylisted. This vulnerability is fixed in 0.2026.05.06.15.42.stable_01.

References

Community reviews

Loading reviews…