Skip to main content
VulnerabilityPublished

CVE-2026-50159: mermaid · Code Injection

Affects mermaidSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 11.16.1 or 10.9.8 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.16.1, 10.9.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade mermaid and mermaid-js/mermaid to 11.16.1 or 10.9.8.

Affected software

ProductAffectedFixed in
mermaid-jsmermaidAffected
  • >=11.0.0-alpha.1 <11.16.1
Fixed in
  • 11.16.1
mermaid-jsmermaidAffected
  • <10.9.8
Fixed in
  • 10.9.8
npmmermaid-js/mermaidpkg:npm/mermaid-js/mermaidOther threatsAffected
  • <10.9.8
  • >=11.0.0 <11.16.1
Fixed in
  • 10.9.8
  • 11.16.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Mermaid to version 10.9.8 or later, or 11.16.1 or later, where this CSS injection vulnerability is fixed. No other mitigation is indicated or required according to the available data.

Description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid is vulnerable to CSS injection via sibling combinator selectors generated from diagram-supplied class or id names. An attacker who can supply diagram text can inject arbitrary CSS into the rendered page, potentially altering the appearance or behavior of unrelated page elements. This issue is fixed in versions 10.9.8 and 11.16.1.

References

Community reviews

Loading reviews…