Skip to main content
VulnerabilityPublished

CVE-2026-53725: parse-server · Information Exposure

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 9.9.1-alpha.5 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9.1-alpha.5
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.9.1-alpha.5.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.8.0 <9.9.1-alpha.5
Fixed in
  • 9.9.1-alpha.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in parse-server version 9.9.1-alpha.5. Users should upgrade to this version or later to remediate the vulnerability. No other mitigation guidance is provided by the vendor advisory. Patch status is not explicitly stated beyond the fixed version, so users should verify the upgrade and test accordingly.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. From version 9.8.0 to before version 9.9.1-alpha.5, apps that enable MFA and deny get on the _User class via Class-Level Permissions could expose sensitive user data through the /login and /verifyPassword endpoints. These endpoints re-fetch the user through the access-controlled query pipeline (CLP, protectedFields, auth-adapter sanitizers) before responding. When that re-fetch was denied by the _User get permission, the server fell back to the raw database row, exposing raw authData (including MFA TOTP secrets and recovery codes) and fields hidden by protectedFields (when protectedFieldsOwnerExempt is false). /verifyPassword is the most severe: with only a username and password (no session or MFA token), an attacker who knows a victim's password could retrieve their MFA secret and recovery codes, defeating the second factor. This issue has been patched in version 9.9.1-alpha.5.

References

Community reviews

Loading reviews…