Skip to main content
VulnerabilityPublished

CVE-2026-32098: parse-server · Information Exposure

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 9.6.0-alpha.9 or 8.6.35 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.9, 8.6.35
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.9 or 8.6.35; parse-community/parse-server to 8.6.35.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.9
Fixed in
  • 9.6.0-alpha.9
parse-communityparse-serverAffected
  • <8.6.35
Fixed in
  • 8.6.35
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.35
Fixed in
  • 8.6.35

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade parse-server to version 9.6.0-alpha.9 or later, or 8.6.35 or later, where the vulnerability is patched. Until upgrades can be applied, organizations should consider disabling LiveQuery subscriptions on classes with protectedFields configured to prevent exploitation. Review and tighten Class-Level Permissions to minimize exposure of sensitive fields. Implement network-level controls such as firewall rules or API gateways to restrict access to LiveQuery endpoints only to trusted clients. Monitor LiveQuery subscription patterns for unusual or suspicious queries that may indicate exploitation attempts. Employ logging and alerting on backend access to detect potential reconnaissance activity. Conduct a thorough audit of data exposure risks in parse-server deployments and apply defense-in-depth controls such as encryption of sensitive data at rest and in transit. Finally, educate developers and administrators about the risks of enabling LiveQuery with protectedFields and encourage timely patch management.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0 and 8.6.35, an attacker can exploit LiveQuery subscriptions to infer the values of protected fields without directly receiving them. By subscribing with a WHERE clause that references a protected field (including via dot-notation or $regex), the attacker can observe whether LiveQuery events are delivered for matching objects. This creates a boolean oracle that leaks protected field values. The attack affects any class that has both protectedFields configured in Class-Level Permissions and LiveQuery enabled. This vulnerability is fixed in 9.6.0 and 8.6.35.

References

Community reviews

Loading reviews…