Skip to main content
VulnerabilityPublished

CVE-2026-54133: jmespath.php · Improper Input Validation

Affects jmespath.phpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.9.1 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.9.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade jmespath.php and jmespath/jmespath.php to 2.9.1.

Affected software

ProductAffectedFixed in
jmespathjmespath.phpAffected
  • <2.9.1
Fixed in
  • 2.9.1
Packagistjmespath/jmespath.phppkg:composer/jmespath/jmespath.phpOther threatsAffected
  • <2.9.1
Fixed in
  • 2.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in jmespath.php version 2.9.1 and later. Users should upgrade to version 2.9.1 or above to remediate this vulnerability. Until upgrading, users should disable JP_PHP_COMPILE and avoid using JmesPath\CompilerRuntime with untrusted or attacker-controlled expressions. Instead, use the default AstRuntime for evaluating untrusted expressions. Applications that must accept untrusted expressions should ensure these are never evaluated by the compiler runtime to prevent code execution.

Description

jmespath.php allows users to use JMESPath, software for declaratively specifying how to extract elements from a JSON document, in PHP applications with PHP data structures. Versions prior to 2.9.1 can generate and execute attacker-controlled PHP code when `JmesPath\CompilerRuntime` is used with an attacker-controlled JMESPath expression. The compiler emits parsed JMESPath function names into generated PHP source without sufficient escaping. A crafted expression can cause the generated cache file to contain executable attacker-controlled PHP, which is then loaded by the compiler runtime. The issue is patched in `2.9.1` and later. As a workaround, disable `JP_PHP_COMPILE` and do not use `JmesPath\CompilerRuntime` with attacker-controlled expressions. Use the default `AstRuntime` for untrusted expressions. Applications that must continue accepting untrusted JMESPath expressions before upgrading should ensure those expressions are never evaluated by the compiler runtime.

References

Community reviews

Loading reviews…