CVE-2026-5627: mintplex-labs/anything-llm · Path Traversal: '\..\filename
Affects mintplex-labs/anything-llmSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 1.12.1 : patch mintplex-labs/anything-llm as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.12.1
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mintplex-labsmintplex-labs/anything-llm | Affected
| Fixed in– |
GitHubmintplex-labs/anything-llmpkg:github/mintplex-labs/anything-llmOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected installations of mintplex-labs/anything-llm to version 1.12.1 or later where the vulnerability is fixed. Until patched, restrict access to the affected component to trusted users only, as the vulnerability requires high privileges to exploit.
Description
CVE-2026-5627 is a critical path traversal vulnerability in mintplex-labs/anything-llm up to version 1.9.1, specifically in the AgentFlows component. It allows attackers with high privileges to bypass directory restrictions via crafted input to loadFlow and deleteFlow methods, potentially accessing or deleting arbitrary JSON files on the server. This can lead to disclosure of sensitive configuration files containing API keys or denial of service by deleting important files like package.json. The vulnerability is fixed in version 1.12.1.