CVE-2026-56778: n8n · Incorrect Authorization
Affects n8nSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.26.2 or 2.25.7 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.26.2, 2.25.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n to 2.26.2 or 2.25.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n n8n | Affected
| Fixed in
|
AI-suggested
The vulnerability is fixed in n8n versions 2.25.7 and 2.26.2. Users should upgrade to at least these versions to remediate the issue. Until patched, restrict sharing of workflows to trusted users and monitor usage of the Public API execution retry endpoint if possible.
Description
CVE-2026-56778 is an authorization bypass vulnerability in n8n versions before 2.25.7 and 2.26.x before 2.26.2. The flaw occurs in the Public API execution retry endpoint, which incorrectly authorizes users with the workflow:read scope to retry workflow executions, a capability intended only for users with workflow:execute permission. This allows authenticated users with read-only access to shared workflows to perform execution retries, violating the intended permission boundaries.