CVE-2026-56360: n8n · Authentication Bypass by Spoofing
Affects n8nSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.6.2 or 1.123.18 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.6.2, 1.123.18
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n to 2.6.2 or 1.123.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n n8n | Affected
| Fixed in
|
AI-suggested
Upgrade n8n to version 1.123.18 or later, or 2.6.2 or later, where the vulnerability is fixed by proper verification of HMAC-SHA256 signatures on Zendesk webhooks. No other mitigation is indicated. Patch status is confirmed by the presence of fixed versions.
Description
CVE-2026-56360 is an authentication bypass vulnerability in n8n versions before 1.123.18 and 2.6.2. The flaw exists because the ZendeskTrigger node does not verify HMAC-SHA256 signatures on incoming Zendesk webhooks. An attacker who knows the webhook URL can send unsigned POST requests to trigger workflows with arbitrary data, potentially causing unintended actions.