Skip to main content
VulnerabilityPublished Updated

CVE-2026-56776: n8n · Incorrect Authorization

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.123.55 when convenient.

Data as of 29 Oct 2026, 19:15 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.17.4
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-07-09.

Patch
Available – fixed in 1.123.55, 2.26.2, 2.25.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
n8nn8nAffected
  • <1.123.55
Fixed in
  • 1.123.55
n8nn8nAffected
  • >=2.26.0 <2.26.2
Fixed in
  • 2.26.2
n8nn8nAffected
  • >=2.0.0-rc.0 <2.25.7
Fixed in
  • 2.25.7
npmn8npkg:npm/n8nOther threatsAffected
  • <1.123.55
  • >=2.26.0 <2.26.2
  • >=2.0.0-rc.0 <2.25.7
Fixed in
  • 1.123.55
  • 2.26.2
  • 2.25.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to these or later versions to remediate the issue. No additional mitigation steps are indicated beyond applying the official patches.

Description

CVE-2026-56776 is an authorization bypass vulnerability in n8n before versions 1.123.55, 2.25.7, and 2.26.2. It affects the POST /workflows/{workflowId}/test-runs/new endpoint, where the system incorrectly authorizes access using the workflow:read scope instead of the required workflow:execute scope. This allows authenticated users with read-only access to trigger real workflow executions, potentially causing unintended outbound API calls, data changes, or other side effects in connected systems. The issue mainly impacts instances using the Evaluations feature with RBAC roles granting workflow:read but not workflow:execute.

References

Community reviews

Loading reviews…