CVE-2026-59259: n8n · Insecure Direct Object Reference
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 6.0 Medium : upgrade to 1.123.61 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.0 |
|---|
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-07-15.
- Patch
- Available – fixed in 1.123.61, 2.28.1, 2.27.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8nn8n | Affected
| Fixed in
|
| n8nn8n | Affected
| Fixed in
|
| n8nn8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade n8n to versions 1.123.61, 2.27.4, or 2.28.1 or later, where this vulnerability is fixed. No other mitigation is indicated. If upgrading is not immediately possible, review external secrets provider configurations and Advanced Permissions usage to limit exposure, but the vendor advisory confirms fixed versions are available.
Description
n8n versions before 1.123.61, 2.27.4, and 2.28.1 have a permission bypass vulnerability related to external secrets handling. Authenticated users with credential create or update permissions but lacking the externalSecret:list scope can embed external secret references that bypass static validation. These references resolve at workflow execution, exposing secret values without proper authorization. This affects instances using an external secrets provider and Advanced Permissions.