CVE-2026-56775: n8n · Incorrect Authorization
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.123.55 when convenient.
Data as of 29 Oct 2026, 18:49 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.4 |
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-07-08.
- Patch
- Available – fixed in 1.123.55, 2.26.2, 2.25.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8nn8n | Affected
| Fixed in
|
| n8nn8n | Affected
| Fixed in
|
| n8nn8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to these or later versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-56775 is an authorization vulnerability in n8n versions before 1.123.55, 2.25.7, and 2.26.2. It affects three mutating evaluation test-run endpoints that incorrectly use the workflow:read scope for authorization instead of the more restrictive workflow:execute scope. This allows authenticated users with the project:viewer role under Advanced Permissions to perform state-changing actions such as starting, canceling, and deleting workflow test runs on workflows they only have read access to.