CVE-2026-56353: n8n · Improper Authentication
Affects n8nSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.9.3 or 1.123.22 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.9.3, 1.123.22
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n to 2.9.3 or 1.123.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n n8n | Affected
| Fixed in
|
AI-suggested
Upgrade n8n to version 1.123.22, 2.9.3, or 2.10.1 or later to apply the official fix for this authentication bypass vulnerability. No other mitigations are indicated.
Description
CVE-2026-56353 is an authentication bypass vulnerability in the n8n automation tool affecting the Chat Trigger node when configured with n8n User Auth, a non-default setting. In affected versions, the authentication check on the Chat Trigger webhook endpoint can be bypassed, allowing unauthorized access. The issue is fixed in versions 1.123.22, 2.9.3, and 2.10.1.