Skip to main content
VulnerabilityPublished Updated

CVE-2026-57112: MervinPraison PraisonAI · Missing Authentication

Affects MervinPraison PraisonAISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.3 High : upgrade to 4.6.59 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.59, 1.6.59
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PraisonAI and praisonai to 4.6.59; praisonaiagents to 1.6.59.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • >=3.10.0 <4.6.59
Fixed in
  • 4.6.59
MervinPraisonpraisonaiagentsAffected
  • >=0.6.0 <1.6.59
Fixed in
  • 1.6.59
PyPIpraisonaipkg:pypi/praisonaiOther threatsAffected
  • >=3.10.0 <4.6.59
Fixed in
  • 4.6.59

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An initial remediation has been released in praisonaiagents version 1.6.59 and PraisonAI version 4.6.59. Users should upgrade to these versions or later to address the vulnerability. No additional mitigation steps are indicated beyond applying the official fix.

Description

CVE-2026-57112 is a high-severity vulnerability in MervinPraison's PraisonAI multi-agent system affecting versions from 0.6.0 up to but not including 1.6.59 and 3.10.0 up to but not including 4.6.59. The issue arises because the legacy SSE wrapper mounts SseServerTransport on /sse and /messages/ endpoints without enforcing Host, Origin, or authentication checks. This allows a malicious website to perform DNS rebinding attacks to enumerate and invoke registered tools with the server user's privileges. An initial fix was released in versions 1.6.59 and 4.6.59.

References

Community reviews

Loading reviews…