Skip to main content
VulnerabilityPublished

CVE-2026-57131: MervinPraison PraisonAI · Code Injection

Affects MervinPraison PraisonAISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.6.48 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.48, 4.6.58
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PraisonAI to 4.6.48; mervinpraison/PraisonAI to 4.6.58.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • <4.6.48
Fixed in
  • 4.6.48
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threatsAffected
  • <4.6.58
Fixed in
  • 4.6.58

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PraisonAI to version 4.6.58 or later, where this vulnerability is fixed. Prior versions are vulnerable due to lack of authentication and authorization on the /api/v1/runs endpoint. No other mitigation is indicated.

Description

PraisonAI is a multi-agent teams system. Prior to 4.6.58, praisonai.jobs.server.create_app mounts praisonai.jobs.router.create_router under /api/v1/runs without authentication or per-job authorization. Network clients can submit attacker-controlled prompts and agent configuration, list and read jobs, stream results, and cancel or delete other jobs, exposing service credentials and connected tool capabilities to unauthorized agent execution. This vulnerability is fixed in 4.6.58.

References

Community reviews

Loading reviews…