CVE-2026-57193: asterisk · Improper Neutralization of Special Elements in Data Query Logic
Affects asteriskSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium · fixed in 23.4.1 : update asterisk when convenient.
Data as of 26 Oct 2026, 20:12 UTC
- Patch
- Available – fixed in 23.4.1, 22.10.1, 21.12.3 +3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskcertified-asterisk | Affected
| Fixed in
|
| asteriskcertified-asterisk | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Asterisk versions 20.20.1, 21.12.3, 22.10.1, 23.4.1, and Certified Asterisk 20.7-cert11, 22.8-cert3. Users should upgrade to these or later versions to remediate the issue. If the res_config_ldap module is not in use, no action is required. Otherwise, apply the official patches by upgrading to the fixed versions.
Description
CVE-2026-57193 is a vulnerability in the Asterisk telephony toolkit's LDAP realtime driver (res_config_ldap) that allows LDAP filter injection via a crafted SIP username. This can enable an unauthenticated attacker to perform arbitrary LDAP queries and potentially disclose information. The vulnerability affects versions prior to 20.20.1, 21.12.3, 22.10.1, 23.4.1, and certain Certified Asterisk releases. The res_config_ldap module must be enabled and configured to access an LDAP server for the issue to be exploitable. Fixed versions are available.
References
- github.com/asterisk/asterisk/security/advisories/GHSA-r6c2-hwc2-j4mp (opens in a new tab)
- github.com/asterisk/asterisk/commit/04aa482212e43b292817444eb4de35499f4b1568 (opens in a new tab)
- github.com/asterisk/asterisk/commit/14968f2f440ea0dd983caa4f477237a5224904dd (opens in a new tab)
- github.com/asterisk/asterisk/commit/23c01b6d359c5d85da725beea89e394a6c031c5d (opens in a new tab)
- github.com/asterisk/asterisk/commit/7e1ae09594a101950398cc6aff2dd2e5ab314884 (opens in a new tab)
- github.com/asterisk/asterisk/commit/8170a6bfa75994e7617a8b9d7fe7a7140b70cbe2 (opens in a new tab)
- github.com/asterisk/asterisk/commit/dd0c768d9e9678e4cb1ed95689a254a61452239b (opens in a new tab)
- github.com/asterisk/asterisk/commit/ef280572a034cac3994075298facb1999778ee0d (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/20.20.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/21.12.3 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/22.10.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/23.4.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/certified-20.7-cert11 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/certified-22.8-cert3 (opens in a new tab)
- github.com/asterisk/asterisk/tree/24.0.0-pre1 (opens in a new tab)