CVE-2026-6108: 1Panel-dev MaxKB · OS Command Injection
Affects 1Panel-dev MaxKBSource CVE Database V5
Public exploit available · CVSS 5.3 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.4% chance of exploitation in 30 days – higher than 73% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 12 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 1Panel-devMaxKB | Affected
| Fixed in– |
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:maxkb:maxkb:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of 1Panel-dev MaxKB has been released by the vendor. Users should upgrade to the latest version beyond 2.6.1 to remediate this vulnerability. Since the vendor has provided an official fix, applying this update is the recommended mitigation. Patch status is confirmed by the vendor's prompt response and release of a fixed version.
Description
A vulnerability was found in 1Panel-dev MaxKB up to 2.6.1. The affected element is the function execute of the file apps/application/flow/step_node/mcp_node/impl/base_mcp_node.py of the component Model Context Protocol Node. Performing a manipulation results in os command injection. The attack is possible to be carried out remotely. The exploit has been made public and could be used. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.