Skip to main content
VulnerabilityPublished Updated

CVE-2026-65100: Apache Traffic Server · Incorrect Behavior Order

Affects Apache Traffic ServerSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium · fixed in 9.2.15 : update Apache Traffic Server when convenient.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.15
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Traffic ServerAffected
  • >=8.0.0 <=8.1.11
  • >=9.0.0 <=9.2.14
  • >=10.0.0 <=10.1.3
Fixed in–

AI-suggested

Users should upgrade Apache Traffic Server to version 9.2.15 or 10.1.4 or later, where this issue is fixed. No other mitigations are specified. Patch status is confirmed by the vendor advisory recommending these versions.

Description

Apache Traffic Server updates the HTTP/2 HPACK dynamic table before confirming the header block encoded successfully, so an encode failure leaves the encoder out of sync with the peer decoder and corrupts subsequent header blocks on the connection. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

References

Community reviews

Loading reviews…