Skip to main content
VulnerabilityPublished Updated

CVE-2026-67404: rabbitmq-server · Improper Certificate Validation

Affects rabbitmq-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.2 Critical · fixed in 4.2.6 : patch rabbitmq-server as a priority.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.6, 4.1.11, 4.0.20 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade rabbitmq-server to 4.2.6, 4.1.11, 4.0.20 or 3.13.15.

Affected software

ProductAffectedFixed in
rabbitmqrabbitmq-serverAffected
  • >=4.2.0 <4.2.6
Fixed in
  • 4.2.6
rabbitmqrabbitmq-serverAffected
  • >=4.1.0 <4.1.11
Fixed in
  • 4.1.11
rabbitmqrabbitmq-serverAffected
  • >=4.0.0 <4.0.20
Fixed in
  • 4.0.20
rabbitmqrabbitmq-serverAffected
  • >=3.13.0 <3.13.15
Fixed in
  • 3.13.15
GitHubrabbitmq/rabbitmq-serverpkg:github/rabbitmq/rabbitmq-serverOther threatsAffected
  • 3.13.0 – 4.2.6
8 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in rabbitmq-server versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0. Users should upgrade to these or later versions to remediate the issue. Ensure that a valid CA bundle is configured and accessible to avoid fallback to insecure verification modes. No other mitigations are indicated by the vendor advisory.

Description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

References

Community reviews

Loading reviews…