Skip to main content
VulnerabilityPublished

CVE-2026-69251: FlowiseAI Flowise · Code Injection

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 9.0 Critical : upgrade to 3.1.3 as a priority.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.7% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Flowise and flowise-components and flowiseai/Flowise to 3.1.3.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.3
Fixed in
  • 3.1.3
FlowiseAIflowise-componentsAffected
  • <3.1.3
Fixed in
  • 3.1.3
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.3
Fixed in
  • 3.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.3 or later, where this vulnerability is fixed. No other mitigation or workaround is specified. Patch status is confirmed fixed in 3.1.3.

Description

Flowise versions prior to 3.1.3 contain a code injection vulnerability in record manager and agent memory nodes. Authenticated users can set arbitrary TypeORM DataSource options via the additionalConfig input, enabling them to load local JavaScript files and execute arbitrary code on the server. This vulnerability is fixed in version 3.1.3.

References

Community reviews

Loading reviews…