Skip to main content
VulnerabilityPublished

CVE-2026-77912: GitHub Enterprise Server · Cross-site Scripting

Affects GitHub Enterprise ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High · fixed in 3.22.1 : patch GitHub Enterprise Server soon.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 4.0 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.22.1, 3.21.6, 3.20.8 +3
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N/AU:Y

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.22.0 <3.22.1
Fixed in
  • 3.22.1
GitHubEnterprise ServerAffected
  • >=3.21.0 <3.21.6
Fixed in
  • 3.21.6
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.8
Fixed in
  • 3.20.8
GitHubEnterprise ServerAffected
  • >=3.19.0 <3.19.12
Fixed in
  • 3.19.12
GitHubEnterprise ServerAffected
  • >=3.18.0 <3.18.15
Fixed in
  • 3.18.15
GitHubEnterprise ServerAffected
  • >=3.17.0 <3.17.21
Fixed in
  • 3.17.21

AI-suggested

Official fixes are available and should be applied immediately. The vulnerability is fixed in GitHub Enterprise Server versions 3.22.1, 3.21.6, 3.20.8, 3.19.12, 3.18.15, and 3.17.21. Administrators should upgrade affected installations to these or later versions to remediate the issue. No additional mitigation steps are indicated beyond applying the official patches.

Description

A stored cross-site scripting (XSS) vulnerability was identified in GitHub Enterprise Server that allowed an authenticated attacker to inject arbitrary HTML attributes into rendered Markdown because the Markdown rendering pipeline rewrote quote characters in already-sanitized HTML without re-sanitizing the result. Crafted Markdown could abuse same-origin JavaScript gadgets to bypass Content Security Policy and gain control of the page DOM when viewed by another user. Successful exploitation could allow an attacker to read content visible to the victim, extract embedded CSRF tokens, perform state-changing actions as the victim, and exfiltrate data through same-origin writes. The payload could also propagate to repositories and organizations where the victim had write access. This vulnerability affected supported GitHub Enterprise Server releases in the 3.17, 3.18, 3.19, 3.20, 3.21, and 3.22 series and was fixed in versions 3.22.1, 3.21.6, 3.20.8, 3.19.12, 3.18.15, and 3.17.21. This vulnerability was reported via the GitHub Bug Bounty program.

References

Community reviews

Loading reviews…