Skip to main content
VulnerabilityPublished

CVE-2026-85036: zephyrproject zephyr · Memory-safety

Affects zephyrproject zephyrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.7 Medium : upgrade to 4.5.0 or 4.3.2 when convenient.

Data as of 4 Nov 2026, 06:28 UTC

CVSS 3.1 base score
5.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (zephyr)CVSS 3.15.7
Patch
Available – fixed in 4.5.0, 4.3.2
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade zephyrproject zephyr to 4.5.0 or 4.3.2.

Affected software

ProductAffectedFixed in
zephyrprojectzephyrAffected
  • >=4.4.0 <4.5.0
Fixed in
  • 4.5.0
zephyrprojectzephyrAffected
  • >=4.3.0 <4.3.2
Fixed in
  • 4.3.2
GitHubzephyrpkg:github/zephyrOther threatsAffected
  • >=4.3.0 <4.3.2
  • >=4.4.0 <4.5.0
Fixed in
  • 4.3.2
  • 4.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and included in Zephyr versions 4.3.2 and 4.5.0. Both commits addressing the issue must be applied together to fully remediate the vulnerability. Users should upgrade affected Zephyr versions to 4.3.2 or 4.5.0 or later. No additional mitigation is required if the fix is applied.

Description

CVE-2026-85036 is a memory-safety vulnerability in the Zephyr project's Bluetooth Classic AVDTP layer affecting versions 4.3.0 up to but not including 4.3.2 and 4.4.0 up to but not including 4.5.0. The flaw arises from improper handling of session stream endpoints during connection reuse, leading to corruption of the system work queue's pending list. This corruption can cause the system work queue to stop processing work or enter a spin loop, resulting in a device-wide denial of service that requires a reboot. The vulnerability affects builds with CONFIG_BT_CLASSIC and CONFIG_BT_A2DP enabled. A two-commit fix is available in versions 4.3.2 and 4.5.0 that must be applied together to fully remediate the issue.

References

Community reviews

Loading reviews…