Skip to main content
VulnerabilityPublished

CVE-2026-86782: Visualizer (WordPress plugin) · Insecure Direct Object Reference

Affects Visualizer (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 4.0.6 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.6
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Visualizer (WordPress plugin) to 4.0.6.

Affected software

ProductAffectedFixed in
VisualizerAffected
  • >=4.0.0 <4.0.6
Fixed in
  • 4.0.6

AI-suggested

Upgrade the Visualizer plugin to version 4.0.6 or later, where this authorization bypass vulnerability has been fixed. No other mitigation steps are indicated.

Description

The Visualizer WordPress plugin before 4.0.6 does not properly authorise access to its chart-building actions, allowing users with the Contributor role and above to publish, rename, and overwrite the content of posts and pages they do not own, including other users' private drafts.

References

Community reviews

Loading reviews…