CVE-2026-93405: Foundry376 Mailspring · Cross-site Scripting
Affects Foundry376 MailspringSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.17.0 when convenient.
Data as of 7 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.17.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade Mailspring and foundry376/Mailspring to 1.17.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Foundry376Mailspring | Affected
| Fixed in
|
GitHubfoundry376/Mailspringpkg:github/foundry376/MailspringOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Mailspring version 1.17.0. Users should upgrade to version 1.17.0 or later to remediate this issue. No other mitigation steps are indicated by the vendor advisory.
Description
Mailspring is a fast, cross-platform, open-source email client. Prior to 1.17.0, attachment quick preview converts Markdown, DOCX, and XLSX attachments with Snarkdown, Mammoth, and SheetJS and inserts the resulting HTML into the preview document through innerHTML without sanitization. A remote sender can craft a supported attachment whose converted HTML executes script when a recipient opens quick preview. The preview renderer has no direct Node or Electron access, but injected script can reach the IPC surface exposed to the quick-preview renderer. This issue alone provides script execution in the preview renderer; separate path-traversal and renderer-controlled file-write vulnerabilities are required for the documented persistent code-execution chain. This issue is fixed in version 1.17.0.
References
- github.com/Foundry376/Mailspring/security/advisories/GHSA-px2g-jhg5-c6gh (opens in a new tab)
- github.com/Foundry376/Mailspring/pull/2523 (opens in a new tab)
- github.com/Foundry376/Mailspring/commit/5728388199666ec0a9a58f693c89c25b948a9b6c (opens in a new tab)
- github.com/Foundry376/Mailspring/releases/tag/1.17.0 (opens in a new tab)