CVE-2026-93592: vllm · Improper Validation of Array Index
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.28.0 soon.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.28.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade vllm and vllm-project/vllm to 0.28.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
GitHubvllm-project/vllmpkg:github/vllm-project/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to vLLM version 0.28.0 or later where this issue is fixed. Since the vulnerability affects versions before 0.28.0, applying the official fix by updating the software is recommended. No vendor advisory or patch link was provided, so confirm the patch availability from the vendor's official channels before deployment.
Description
vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative token IDs. A single request with a negative token ID triggers a CUDA device-side assertion that poisons the GPU context, causing all subsequent requests to fail until the process restarts.