DOMPurify before 3.4.17 contains a cross-site scripting vulnerability that allows attackers to keep event handlers
Affects dompurifySource GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 3.4.17 when convenient.
Data as of 27 Oct 2026, 02:12 UTC
- Patch
- Available – fixed in 3.4.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade dompurify to 3.4.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmdompurifypkg:npm/dompurifyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in DOMPurify version 3.4.17 and later. Users should upgrade to version 3.4.17 or newer to remediate this vulnerability. No other mitigation steps are indicated or necessary according to the provided data.
Description
DOMPurify versions before 3.4.17 contain a cross-site scripting (XSS) vulnerability. This flaw allows attackers to retain event handlers in detached DOM subtrees that are not sanitized, enabling malicious event handlers like img onerror to execute after the sanitize() function completes. The vulnerability arises when an IN_PLACE hook removes a parent or sibling node, leaving attacker-controlled markup unneutralized.