Skip to main content
VulnerabilityPublished

@evomap/evolver: Path Traversal

Affects @evomap/evolverSource GCVE Database

0

CVSS 8.8 High : upgrade to 1.70.0-beta.5 soon.

Data as of 27 Oct 2026, 01:49 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.70.0-beta.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade @evomap/evolver to 1.70.0-beta.5.

Affected software

ProductAffectedFixed in
npm@evomap/evolverAffected
  • <1.70.0-beta.5
Fixed in
  • 1.70.0-beta.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 1.70.0-beta.5 is available that addresses this vulnerability. Users should upgrade to version 1.70.0-beta.5 or later. Until upgraded, avoid running `evolver fetch` without the `--out` flag or only use trusted Hubs. The vendor advisory confirms a patch is available. No other mitigations are documented.

Description

A path traversal vulnerability exists in the `evolver fetch` subcommand of @evomap/evolver before version 1.70.0-beta.5. The sanitization of the Hub-supplied `skill_id` allows `..` to bypass checks and cause files to be written outside the intended directory, specifically into the user's current working directory. This enables an attacker controlling the Hub or a malicious participant to overwrite critical files such as `index.js` or `package.json`, leading to remote code execution on subsequent runs of evolver.

References

Community reviews

Loading reviews…