Skip to main content
VulnerabilityPublished

@evomap/evolver's validator sandbox allowlist permits `npm`/`npx`, yielding RCE from Hub-delivered validation tasks

Affects @evomap/evolverSource GCVE Database

0

CVSS 8.1 High : upgrade to 1.70.0-beta.5 soon.

Data as of 27 Oct 2026, 01:49 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.70.0-beta.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade @evomap/evolver to 1.70.0-beta.5.

Affected software

ProductAffectedFixed in
npm@evomap/evolverAffected
  • <1.70.0-beta.5
Fixed in
  • 1.70.0-beta.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 1.70.0-beta.5 that addresses this vulnerability. Users should upgrade to this version or later to remediate the issue. Until patched, disabling validator mode or restricting network access to the Hub may reduce exposure, but the primary mitigation is to apply the official fix.

Description

The @evomap/evolver validator sandbox executor includes 'npm' and 'npx' in its hardcoded executable allowlist, enabling remote code execution (RCE) via Hub-delivered validation tasks. The validator daemon fetches validation commands from the Hub without verifying the response signature, allowing an attacker controlling or man-in-the-middling the Hub to execute arbitrary code on validator nodes. The sandbox does not restrict 'npm' or 'npx' commands, which can run lifecycle scripts or remote binaries, leading to full code execution with the validator process's permissions. This vulnerability affects versions prior to 1.70.0-beta.5 and is patched in that release.

References

Community reviews

Loading reviews…