Skip to main content
VulnerabilityPublished Updated

CVE-2026-42076: Evolver · Command Injection via `execSync` in `_extractLLM()` function allows Remote Code Execution

Affects @evomap/evolverSource GCVE Database

0
Authoritative record:CVE-2026-42076· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.69.3 as a priority.

Data as of 27 Oct 2026, 01:24 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.69.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade @evomap/evolver to 1.69.3.

Affected software

ProductAffectedFixed in
npm@evomap/evolverAffected
  • <1.69.3
Fixed in
  • 1.69.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 1.69.3 of @evomap/evolver. Users should upgrade to version 1.69.3 or later to remediate this vulnerability. Until patched, avoid processing untrusted user input in the affected functions or apply strict input validation and sanitization to prevent shell metacharacters from being passed to execSync().

Description

A command injection vulnerability in the _extractLLM() function of the @evomap/evolver package allows remote attackers to execute arbitrary shell commands. The vulnerability arises from unsafe string concatenation of user-controlled input into a curl command executed via execSync() without proper sanitization. This enables remote code execution with the privileges of the Node.js process. The issue affects versions prior to 1.69.3 and has a critical severity score of 9.8. A fix is available in version 1.69.3.

References

Community reviews

Loading reviews…