Skip to main content
CVE-2026-119190VulnerabilityPublished

verifyCertificateChain() · Forge: X.509 basicConstraints bypass

Affects node-forgeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119190· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 1.4.1 soon.

Data as of 31 Oct 2026, 02:05 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.4
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade node-forge to 1.4.1.

Affected software

ProductAffectedFixed in
npmnode-forgeAffected
  • <1.4.1
Fixed in
  • 1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in node-forge version 1.4.1, which restricts certificate chain verification to the standard basicConstraints extension OID 2.5.29.19. Users should upgrade to node-forge 1.4.1 or later. No effective workaround exists within node-forge itself. Applications that provide a custom verify callback to forge.pki.verifyCertificateChain() can implement additional checks to reject chains where non-leaf certificates lack a 2.5.29.19 basicConstraints extension with cA TRUE. Certificate authorities should avoid copying unrecognized extensions from certificate requests to prevent issuing vulnerable certificates.

Description

node-forge versions prior to 1.4.1 improperly handle deprecated X.509 certificate extension OIDs 2.5.29.10 and 2.5.29.13 by treating them as basicConstraints. This allows an attacker with a certificate containing a forged deprecated extension indicating CA privileges (cA TRUE) before the genuine basicConstraints extension (cA FALSE) to bypass CA validation checks. The vulnerability enables issuance of certificates accepted as CA certificates, potentially allowing impersonation in TLS connections. The issue is fixed in node-forge 1.4.1 by restricting verification to the standard basicConstraints OID 2.5.29.19.

References

Community reviews

Loading reviews…